Про проєкт Мобільна версія Статті партнерів Реклама Крипта E-bike
Xiaomi Apple Samsung Google Huawei Oppo Vivo Realme Microsoft AnTuTu
iLenta

Android 14 заблокує встановлення застарілих програм

24 січня 2023, 11:07 | Roter [282]
У проєкті Android Open Source Project (AOSP) з'явилася зміна, яка посилює вимогу системи до версії SDK програми, що встановлюється. На це звернуло увагу видання 9to5Google.
Android 14 заблокує встановлення застарілих програм

У наступній версії операційної системи новий механізм блокуватиме встановлення програм, які створені для занадто старих версій Android. Згодом поріг буде збільшено до Android 6.0 Marshmallow; механізм містить інструмент зміни цього ліміту.

«Ця зміна допомагає підвищити безпеку та конфіденційність, оскільки шкідливе програмне забезпечення може спеціально використовувати більш старі версії SDK, щоб уникнути примусового застосування сучасних API», — з коментарів до зміни коду в AOSP.

Уточнюється, що користувач зможе обійти обмеження через введення спеціальної команди у командному рядку.

Google поступово посилює вимоги до програм, що публікуються в Google Play. Зараз у магазині можуть розміщуватись програми, написані як мінімум під Android 12.

Джерело: 9to5google

Теги: Google Android
YouTube Telegram
Коментарі

ОГЛЯДИ

НОВИНИ ТА ПОДІЇ

ПРИСТРОЇ ТА АКСЕСУАРИ

ІНСТРУКЦІЇ, ПОРАДИ ТА СЕКРЕТИ

КРИПТОВАЛЮТИ

Google News
Ads
Ads
Ads