Про проєкт Мобільна версія Статті партнерів Реклама Крипта E-bike
Xiaomi Apple Samsung Google Huawei Oppo Vivo Realme Microsoft AnTuTu
iLenta

Android 15 забороняє встановлення застосунків, які написані під Android 6.0 та старше

24 березня 2024, 22:07 | Anton Petrov [268]
Нещодавно розробники Google випустили попередню збірку майбутньої операційної системи Android 15 Developer Preview 2.
Android 15 забороняє встановлення застосунків, які написані під Android 6.0 та старше

Особливістю збірки є обмеження на встановлення застарілих програм. Про це розповів авторитетний інсайдер Мішаал Рахман.

За його словами, він виявив, що у тестовій версії Android 15 немає можливості встановити програми з версією SDK нижче 24, що відповідає версії Android 7.0 Nougat. Це говорить про те, що софт, написаний під Android 6.0 Marshmallow і старіших версій, не може бути встановлений на смартфонах з Android 15. Причому обмеження діє і при встановленні APK-файлу.

І це вписується в логіку Google щодо посилення безпеки своєї операційної системи. Наприклад, на Android 14 вже не можна встановити програмне забезпечення, яке було написане під Android 5.1 і старіше. А з серпня 2023 року Google Play не приймає до публікації програми з SDK версії нижче 33 — мінімальною версією може бути лише Android 13.

Рахман розповів, що можна скористатися обходом цих обмежень. Він порадив зробити таке: програму можна встановити через ADB-команду «adb install --bypass-low-target-sdk-block FILENAME.apk» у «FILENAME» слід вписати назву встановлюваного застосунку.

Джерело: androidpolice

Теги: Google Android
YouTube Telegram
Коментарі

ОГЛЯДИ

НОВИНИ ТА ПОДІЇ

ПРИСТРОЇ ТА АКСЕСУАРИ

ІНСТРУКЦІЇ, ПОРАДИ ТА СЕКРЕТИ

КРИПТОВАЛЮТИ

Google News
Ads
Ads
Ads